summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-09-27 08:49:12 -0400
committerMike Gilbert <floppym@gentoo.org>2015-09-27 08:49:12 -0400
commit7d482d7eae4fd3b807a7a4a4ebbf09cb9e25700d (patch)
tree4fc6060a7aec66bcad3de08e5662865e3844f512 /dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
parentwww-client/chromium: Beta channel bump (46.0.2490.42) (diff)
downloadgentoo-7d482d7eae4fd3b807a7a4a4ebbf09cb9e25700d.tar.gz
gentoo-7d482d7eae4fd3b807a7a4a4ebbf09cb9e25700d.tar.bz2
gentoo-7d482d7eae4fd3b807a7a4a4ebbf09cb9e25700d.zip
dev-python/google-apputils: Fix permissions on unpacked files
Bug: https://bugs.gentoo.org/561266 Package-Manager: portage-2.2.22_p3
Diffstat (limited to 'dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild')
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild b/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..613b4dcc6735
--- /dev/null
+++ b/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 ) # Doesn't yet support py3
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for building Python applications"
+HOMEPAGE="https://github.com/google/google-apputils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/python-dateutil-1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-1.4[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2010[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"
+
+src_unpack() {
+ default
+ find ${P} -type d -exec chmod 0755 {} + || die
+ find ${P} -type f -exec chmod 0644 {} + || die
+}
+
+python_test() {
+ # These yield 2 fails which are in fact expected errors run from a shell script!
+ # They seemingly have no immediate mechanism to exit 0 in an expected fail style.
+ for test in tests/{app_test*.py,[b-s]*.py} ; do
+ "${PYTHON}" $test || die "test failure under ${EPYTHON}"
+ done
+}