summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-09 03:37:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-09 04:10:21 +0200
commitab18347742b55c14c4858050c85333a2594f7407 (patch)
tree3f5e24a3cc4a886cae55bd29655573dc0f479f52 /dev-python/google-auth
parentdev-python/google-auth-oauthlib: Bump to 1.2.1 (diff)
downloadgentoo-ab18347742b55c14c4858050c85333a2594f7407.tar.gz
gentoo-ab18347742b55c14c4858050c85333a2594f7407.tar.bz2
gentoo-ab18347742b55c14c4858050c85333a2594f7407.zip
dev-python/google-auth: Bump to 2.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.32.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index fb97b74290df..7b2dbe8ace52 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-2.30.0.tar.gz 251462 BLAKE2B 63deab7b36e79a590348f6e0cfa5c1c0e0715468d35dfcb0e7227932d4d543953668ec4c4b78a087ee1fc22a37bfbc913f07c428f02fa894d28228fae68d0942 SHA512 23ebaf17c12d745214405867661b85eb628dafbc06b87f101ad10d4c4ea8e2cea04a4c9b0c0037ba8f0d8cc12c2221bd4199613fe3c3e3987c72525cb94a5bd3
DIST google-auth-2.31.0.tar.gz 252986 BLAKE2B 50e7554feadaa19644a2f41152d0d255729d19fbd9b6e1967233f9bfdb79968f45e2179effd73b0ab513b25255371b43aab946668aeb7155c827b536e4005afb SHA512 2a2eec2f3638ab855d20827068d64a9adb856d341fc70bdb6401813543f73631d998c38f8350e9ed2a85897b7f0ed7401fc973b066ee2b77ac7ff746dcd7315f
+DIST google_auth-2.32.0.tar.gz 254614 BLAKE2B fc419f1d751cf99497fb00c4cc5b8ff25380a3341970aa31bebadc5f0a84efd8b9d806f939c9137fd872063d6b3cd06eff0629beab8194e0bf6f7323124f8f90 SHA512 d72d9c367a47b3496dcaae9deec29315c65e43ddf9b3ee2838232ed2ac8aabdf5c91978a6d66700b5e9e77a0de8820ecf12b798fb65383600e08d47b732d1981
diff --git a/dev-python/google-auth/google-auth-2.32.0.ebuild b/dev-python/google-auth/google-auth-2.32.0.ebuild
new file mode 100644
index 000000000000..58bd56b3ea38
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.32.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}