summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-04 07:27:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-04 07:34:12 +0200
commit7965a02b6a7bd4b0e7e7f2cb658e012637812562 (patch)
tree489b36535c1d4652c3a02579effec2db3fae82fe /dev-python/googleapis-common-protos
parentdev-python/requests-kerberos: Bump to 0.15.0 (diff)
downloadgentoo-7965a02b6a7bd4b0e7e7f2cb658e012637812562.tar.gz
gentoo-7965a02b6a7bd4b0e7e7f2cb658e012637812562.tar.bz2
gentoo-7965a02b6a7bd4b0e7e7f2cb658e012637812562.zip
dev-python/googleapis-common-protos: Bump to 1.63.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/googleapis-common-protos')
-rw-r--r--dev-python/googleapis-common-protos/Manifest1
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/Manifest b/dev-python/googleapis-common-protos/Manifest
index 014473916387..7c33d4f6f567 100644
--- a/dev-python/googleapis-common-protos/Manifest
+++ b/dev-python/googleapis-common-protos/Manifest
@@ -1 +1,2 @@
DIST googleapis-common-protos-1.63.0.tar.gz 121646 BLAKE2B 6c611a4a83e7e32680e5a333d1de2c5a68ae0fdda73e32a9136b8c9d9c11427768703b0a0e31c72feef70e29685cbd2e30f6d92ced5d16a18eb6281c243d8dc9 SHA512 dd0964057394c1c7220ffee757467ae3e221278790acc560180bf036b0759eb4fa2d65231fa82c1e22bae1068ffd2a089b234face4829c42352223da59f88e87
+DIST googleapis-common-protos-1.63.1.tar.gz 121632 BLAKE2B 1734a3298a525dc720b4dc930312e84791082ad8a2c0a32460156960e7bd109977377c5ccc5432763348461ac42dff64a886676df9ac7805c505d4463a892c38 SHA512 b5775e484f6710bf9fad9097e0a1b9cd978688a5803d9cfbcb05421add3e77b0e858db7fb8896afe34ab81eabeb951d7516d93b45c29ebec518589b12f8abd50
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild
new file mode 100644
index 000000000000..0848eb13e75e
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-common-protos/
+ https://pypi.org/project/googleapis-common-protos/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code