summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 09:47:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 11:08:23 +0100
commitdc6e2d61122dfc8e9fc6a79e4d47f3344c724b8c (patch)
treefa1c6b6c0d322bf52e708410513e366fe457f6f0 /dev-python/googleapis-common-protos
parentdev-python/pytest: Bump to 7.1.1 (diff)
downloadgentoo-dc6e2d61122dfc8e9fc6a79e4d47f3344c724b8c.tar.gz
gentoo-dc6e2d61122dfc8e9fc6a79e4d47f3344c724b8c.tar.bz2
gentoo-dc6e2d61122dfc8e9fc6a79e4d47f3344c724b8c.zip
dev-python/googleapis-common-protos: Bump to 1.56.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/googleapis-common-protos')
-rw-r--r--dev-python/googleapis-common-protos/Manifest1
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/Manifest b/dev-python/googleapis-common-protos/Manifest
index b2c19032f119..f25238b7756a 100644
--- a/dev-python/googleapis-common-protos/Manifest
+++ b/dev-python/googleapis-common-protos/Manifest
@@ -1,2 +1,3 @@
DIST googleapis-common-protos-1.54.0.tar.gz 112874 BLAKE2B 95d2429d8bf27299ff406d0a06f31b2b499f66533cf884a8ec77ed6defa10bdabd6460232265efc9606e5f890ab14c571a0240e842fbdf7117ff3d7bff5ef28d SHA512 535cf6e4e5331a99232cb3eec1bc56676fcf87c522bd5b06f3452c7b22abd51479f3e4c69c8654bba4d789e8267360e11573d357ac90bb63854281e227eb8bc6
DIST googleapis-common-protos-1.55.0.tar.gz 115218 BLAKE2B e0091aa07e42c56a0e8f9502d786b7d775672dab1b19dc9cff41e9dc4a0eb8b4aa05b2ba22d8353466ee6d1a40e94a423dd7ab94564166d0575f827a08dc5dd9 SHA512 3fe171bb54b9f508e524bf6e25e7533549346f3d70f0a55f2117c0031d823646b6384491ab059eddedfaf23ddcf7bdee4f6a66dcd50930403a1b7da5ee0ac9f8
+DIST googleapis-common-protos-1.56.0.tar.gz 132706 BLAKE2B a0adf6527c24aaa30922800a80ef4af8abf3d83c4639c227a859c92e02d248f44b408f98820387a51b310dedf005872cb0fa7824bd27ac6309f31f85810edd40 SHA512 ef6ed067457aad3b46d81bacbb66abe3b36b0640290e0047ef7c6d612dfd8bf865dad47c77275f0d5a1e03cd4e5dca32d08f44c7a7bfe7b264ee59e5c5bb9a27
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0.ebuild
new file mode 100644
index 000000000000..1c0a1b2d5294
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="https://pypi.org/project/googleapis-common-protos/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12.0[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code