summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Linder <linder.gabriel@gmail.com>2019-07-04 15:35:51 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-13 07:42:19 +0300
commit6c7bb2f938eb04b61b18a521739ca7af2aabf5ae (patch)
tree73f95cd0d1ffe58662d0d656c1deb989db9b3018 /dev-python/greenstalk/greenstalk-1.0.1.ebuild
parentsys-apps/dbus-broker: bump to 21 (diff)
downloadgentoo-6c7bb2f938eb04b61b18a521739ca7af2aabf5ae.tar.gz
gentoo-6c7bb2f938eb04b61b18a521739ca7af2aabf5ae.tar.bz2
gentoo-6c7bb2f938eb04b61b18a521739ca7af2aabf5ae.zip
dev-python/greenstalk: bump to version 1.0.1.
Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com> Package-Manager: Portage-2.3.69, Repoman-2.3.17 Closes: https://github.com/gentoo/gentoo/pull/12387 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/greenstalk/greenstalk-1.0.1.ebuild')
-rw-r--r--dev-python/greenstalk/greenstalk-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/greenstalk/greenstalk-1.0.1.ebuild b/dev-python/greenstalk/greenstalk-1.0.1.ebuild
new file mode 100644
index 000000000000..98bafab82c34
--- /dev/null
+++ b/dev-python/greenstalk/greenstalk-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A Python 3 client for the beanstalkd work queue"
+HOMEPAGE="https://greenstalk.readthedocs.io/ https://github.com/mayhewj/greenstalk"
+SRC_URI="https://github.com/mayhewj/greenstalk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ app-misc/beanstalkd
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pytest -v tests.py || die
+}