summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 11:40:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 13:18:40 +0200
commit98bd90391a524fee55aad0866b2b891c1f324993 (patch)
tree304d636c75788099c468125901b3af3a38326563 /dev-python/h5py
parentdev-python/xcffib: Remove old (diff)
downloadgentoo-98bd90391a524fee55aad0866b2b891c1f324993.tar.gz
gentoo-98bd90391a524fee55aad0866b2b891c1f324993.tar.bz2
gentoo-98bd90391a524fee55aad0866b2b891c1f324993.zip
dev-python/h5py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest1
-rw-r--r--dev-python/h5py/h5py-3.6.0.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index 4a21a685da16..27f6546d3831 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,2 +1 @@
-DIST h5py-3.6.0.tar.gz 384160 BLAKE2B 354764bb002cd342623aa962de88a24ee45156c0a2d61088508017980e407e90f85e65da9d3e29a6745dbca754ba1708700fbea4f4123a10a620bc758cbaa3ae SHA512 f3a108d16578ced552fcac4fceb7f3180ee71a3c8f6caa8702fd9989728d8284afb9d85f1239648e10d14f3532c772f46d05f8306bb8b305d98b162d7604683b
DIST h5py-3.7.0.tar.gz 392355 BLAKE2B efc974ff14457ef00329c6b2adf5b926e2dff33bbb4b9e9d60773760a973214c5279bfafca87c6fcab02bbffb85b780c708d26fb55a1e7a401d8d676f20acc15 SHA512 c10a9a623c88dbc965238cb2057b8924492c762c29610cfdb24f26f878a7322e414d3e5c90d750c2f5cfe1b4949f884bc17f09a126b01a4721ad6e14761174a2
diff --git a/dev-python/h5py/h5py-3.6.0.ebuild b/dev-python/h5py/h5py-3.6.0.ebuild
deleted file mode 100644
index bbfbfbcd2ca0..000000000000
--- a/dev-python/h5py/h5py-3.6.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="
- https://www.h5py.org/
- https://github.com/h5py/h5py/
- https://pypi.org/project/h5py/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-# disable mpi until mpi4py gets python3_8
-#IUSE="examples mpi"
-IUSE="examples"
-
-#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
-DEPEND="
- sci-libs/hdf5:=[hl(+)]
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/QtPy[testlib,${PYTHON_USEDEP}]
- )
-"
-# mpi? ( virtual/mpi )
-# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-#pkg_setup() {
-# use mpi && export CC=mpicc
-#}
-
-python_prepare_all() {
- # avoid pytest-mpi dep, we do not use mpi anyway
- sed -i -e 's:pytest-mpi::' pytest.ini || die
- distutils-r1_python_prepare_all
-
- export H5PY_SETUP_REQUIRES=0
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- epytest -m "not mpi"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}