summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-11 15:16:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-11 15:19:00 +0200
commitf116ad851d13bfb73ed529ffb6c8c4f8d1debc41 (patch)
treeb0dde4d35d15f50f36ff8a7f5cbf8eabcc2495ed /dev-python/hatch-fancy-pypi-readme
parentdev-python/krb5: Remove old (diff)
downloadgentoo-f116ad851d13bfb73ed529ffb6c8c4f8d1debc41.tar.gz
gentoo-f116ad851d13bfb73ed529ffb6c8c4f8d1debc41.tar.bz2
gentoo-f116ad851d13bfb73ed529ffb6c8c4f8d1debc41.zip
dev-python/hatch-fancy-pypi-readme: Bump to 22.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatch-fancy-pypi-readme')
-rw-r--r--dev-python/hatch-fancy-pypi-readme/Manifest1
-rw-r--r--dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/hatch-fancy-pypi-readme/Manifest b/dev-python/hatch-fancy-pypi-readme/Manifest
index a157a6e7ff60..d6a4bf33f145 100644
--- a/dev-python/hatch-fancy-pypi-readme/Manifest
+++ b/dev-python/hatch-fancy-pypi-readme/Manifest
@@ -1,2 +1,3 @@
DIST hatch-fancy-pypi-readme-22.3.0.gh.tar.gz 22107 BLAKE2B 7358a35ed9176d5107d406c1f99cfcf17ce409224dcad55ac845087e2fd6cc9ab88e5ea929e3b1304bbff6464cbbbd0b0d9716bcfe199dcd887c809cd6a9356a SHA512 93fe293ddce6dde450bc427d8fa492cf2b1f7d4a0e2d754873f765f588a962ca2c7c48b515ba613503bed6100b302ed91bbedb4d6a9f8d7bc10ab4b1418164e8
DIST hatch-fancy-pypi-readme-22.5.0.gh.tar.gz 27046 BLAKE2B 9ad22d9c8a694a9580efe436a65d14a906b9bc2da6f9bdac0488bb69c6bead31b7a54162f3d3e444ee00d4b73c451b95bdd41ae07f584a65ce1cd5b6d663f257 SHA512 4652e40e45eab3606e53b8f9915247687088ffd7dbfa6ad00f4507a62c0225e72b1f66a21ab6e1cdc98386958eed8c2991facd75ee4295fa078995e1344e1b25
+DIST hatch-fancy-pypi-readme-22.6.0.gh.tar.gz 27232 BLAKE2B ffc2caa36987858be67584ad84e6d76e43411b20986c35a191cccb7209276de3f0faba778a599ad20aad4e15f2d0bb490d8d8f3fb1d274cb93549a53d572ce24 SHA512 293344120a950be25fff6de1fb682ca91686c3ac70619a5cdde45d157a8b8b7359d208bfb41715c214268ac9df2e8c724ab385a52b6d78ebade352833766fe28
diff --git a/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.6.0.ebuild b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.6.0.ebuild
new file mode 100644
index 000000000000..3a081f252756
--- /dev/null
+++ b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Fancy PyPI READMEs with Hatch"
+HOMEPAGE="
+ https://pypi.org/project/hatch-fancy-pypi-readme/
+ https://github.com/hynek/hatch-fancy-pypi-readme
+"
+SRC_URI="
+ https://github.com/hynek/hatch-fancy-pypi-readme/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for self build a wheel? No need for that and fails.
+ tests/test_end_to_end.py
+)