summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-04-07 00:32:11 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-04-07 00:33:34 +0000
commit7ff820bd16a62c600fe14f56b9fb3b147c3102f6 (patch)
treec59a7d753ed5eef1b63bcaa68733b5d5fc9afd3b /dev-python/healpy/healpy-1.9.1.ebuild
parentsci-astronomy/healpix: initial import (diff)
downloadgentoo-7ff820bd16a62c600fe14f56b9fb3b147c3102f6.tar.gz
gentoo-7ff820bd16a62c600fe14f56b9fb3b147c3102f6.tar.bz2
gentoo-7ff820bd16a62c600fe14f56b9fb3b147c3102f6.zip
dev-python/healpy: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/healpy/healpy-1.9.1.ebuild')
-rw-r--r--dev-python/healpy/healpy-1.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/healpy/healpy-1.9.1.ebuild b/dev-python/healpy/healpy-1.9.1.ebuild
new file mode 100644
index 000000000000..9f11d2313d6a
--- /dev/null
+++ b/dev-python/healpy/healpy-1.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for healpix"
+HOMEPAGE="https://github.com/healpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/healpix:=[cxx]
+ sci-libs/cfitsio:="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst CHANGELOG.rst CITATION )
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. esetup.py test || die
+ rm matplotlibrc || die
+}