summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 07:58:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 08:48:36 +0100
commitbf535c90e0805239a407494c894af3e3114596d2 (patch)
treec56978ee52c0c7e0817ff58002629923e39bbf0e /dev-python/humanize
parentdev-python/wcwidth: Bump to 0.2.12 (diff)
downloadgentoo-bf535c90e0805239a407494c894af3e3114596d2.tar.gz
gentoo-bf535c90e0805239a407494c894af3e3114596d2.tar.bz2
gentoo-bf535c90e0805239a407494c894af3e3114596d2.zip
dev-python/humanize: Bump to 4.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.9.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 7142ba5f727a..fcb410323166 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-4.8.0.tar.gz 72894 BLAKE2B 905c9499c9e57959cda3c66d98f4ddb1ddd04278ad53e1d139ca5ff65cf84d526ec7ba5766a6fffecda7e4f31ce9a6b1e59c377b7f37bad3c929ea3bcc77d44f SHA512 2372b9518c6037bbd6bda341cce7f04e6acd0f68c1fe7218e3201477ce12324f6b98efca2bc7024222bfcc222840cd5a6a04649269c86ded7bb81b30d1602cc9
+DIST humanize-4.9.0.tar.gz 78465 BLAKE2B bb13199f7ed9b833891e1e5f166dce33e167224c5fb75ab33130a551680e802aa347f5e19cd1162caa79917af6e0acbbb36226d5051a9d4eef07bc554ba0e19e SHA512 64238f6717302cec4cac853fd2813647132eb4f6cd73cc61fd43346577cd42bbc2cf5a7345910393cd9a4e9c2b5e949a50c6259b0bd8254a05e08d0d8d70a5d5
diff --git a/dev-python/humanize/humanize-4.9.0.ebuild b/dev-python/humanize/humanize-4.9.0.ebuild
new file mode 100644
index 000000000000..681e01638c1b
--- /dev/null
+++ b/dev-python/humanize/humanize-4.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest