summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 06:52:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 06:57:12 +0200
commit14b8768ce79cbaf2a932b7bb5565502d0cd8384d (patch)
tree7e6fca4ffe36eeaf24ac363fbbfd4e8fe0b5189d /dev-python/hypothesis/hypothesis-6.13.5.ebuild
parentdev-python/nuitka: Add python@ as co-maint. (diff)
downloadgentoo-14b8768ce79cbaf2a932b7bb5565502d0cd8384d.tar.gz
gentoo-14b8768ce79cbaf2a932b7bb5565502d0cd8384d.tar.bz2
gentoo-14b8768ce79cbaf2a932b7bb5565502d0cd8384d.zip
dev-python/hypothesis: Bump to 6.13.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis/hypothesis-6.13.5.ebuild')
-rw-r--r--dev-python/hypothesis/hypothesis-6.13.5.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-6.13.5.ebuild b/dev-python/hypothesis/hypothesis-6.13.5.ebuild
new file mode 100644
index 000000000000..22d9efb5231d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.13.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3_{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}