summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-22 07:02:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-22 07:02:05 +0200
commit22bfeeb1017e06df98d5d4dfdab1890e540ab68e (patch)
treec00df1c845f9804ce3fe2425f1530cf6645dacf2 /dev-python/immutabledict/immutabledict-3.0.0.ebuild
parentdev-python/mido: Bump to 1.3.0 (diff)
downloadgentoo-22bfeeb1017e06df98d5d4dfdab1890e540ab68e.tar.gz
gentoo-22bfeeb1017e06df98d5d4dfdab1890e540ab68e.tar.bz2
gentoo-22bfeeb1017e06df98d5d4dfdab1890e540ab68e.zip
dev-python/immutabledict: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/immutabledict/immutabledict-3.0.0.ebuild')
-rw-r--r--dev-python/immutabledict/immutabledict-3.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/immutabledict/immutabledict-3.0.0.ebuild b/dev-python/immutabledict/immutabledict-3.0.0.ebuild
new file mode 100644
index 000000000000..3884d17d62bb
--- /dev/null
+++ b/dev-python/immutabledict/immutabledict-3.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An immutable wrapper around dictionaries"
+HOMEPAGE="
+ https://github.com/corenting/immutabledict/
+ https://pypi.org/project/immutabledict/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest