summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 15:24:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 16:18:56 +0100
commitbb1faeff674abdd507fa8f9b98e1b40e6a68ec99 (patch)
tree360d41b579598dcb0123d735fa01e346972942a5 /dev-python/indexed-gzip
parentdev-python/trove-classifiers: Bump to 2023.11.7 (diff)
downloadgentoo-bb1faeff674abdd507fa8f9b98e1b40e6a68ec99.tar.gz
gentoo-bb1faeff674abdd507fa8f9b98e1b40e6a68ec99.tar.bz2
gentoo-bb1faeff674abdd507fa8f9b98e1b40e6a68ec99.zip
dev-python/indexed-gzip: Bump to 1.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed-gzip')
-rw-r--r--dev-python/indexed-gzip/Manifest1
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/indexed-gzip/Manifest b/dev-python/indexed-gzip/Manifest
index bf3218699d0b..f5b28859b80d 100644
--- a/dev-python/indexed-gzip/Manifest
+++ b/dev-python/indexed-gzip/Manifest
@@ -1 +1,2 @@
DIST indexed_gzip-1.8.5.tar.gz 74696 BLAKE2B 5db7a9c372950e60f4e6f5905a6bf5b01c76007174a77393176d969e87197beefc81d72e5280ac057fcfd3c752e5f8b2923326e3ed2e825fd34315dd23a179b0 SHA512 617b7406ff2e579c41ceafcfb64bd9ba33599f9f810afb5b3abad49825ae274265b8f8eeaf54285d8df11dd9c498a13752455263a51817be11301ed73aeb0230
+DIST indexed_gzip-1.8.7.tar.gz 74172 BLAKE2B a3feddb50a165a73dcf5af79f1470c0ec2933002ef162fc323a66d8d4782b318f52dd92ca81f413b6b4571f2fcc5be7f74e088de6876bd180a2cf7d3360f18b9 SHA512 89b902d3511927d45d424ea09dfcec3037ec1f295cdac30aa5ae50d664bdb75ef1bdaad6e12f317a51bb9c01485aa09d2c0a07923b544307f762dc280048327a
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild
new file mode 100644
index 000000000000..45265669e01d
--- /dev/null
+++ b/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="
+ https://pypi.org/project/indexed-gzip/
+ https://github.com/pauldmccarthy/indexed_gzip/
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_compile() {
+ # This actually enables line tracing, so it fits USE=debug more.
+ if use debug; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ # Fix implicit dependency on numpy that is used to build test
+ # extensions.
+ if ! use test; then
+ local -x PYTHONPATH="${T}:${PYTHONPATH}"
+ cat >> "${T}"/numpy.py <<-EOF || die
+ raise ImportError("I am not here!")
+ EOF
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
+ epytest
+ # temporary files and test extensions
+ # (to achieve equivalence with USE=-test)
+ rm ctest*.{c,gz,so,tmp} || die
+}