summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-17 18:52:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-17 18:53:59 +0200
commit552dbafd02e83465ee91c03306da41ec28618179 (patch)
tree3db5724988dac30754be909bb11bdc034a125010 /dev-python/indexed_gzip
parentdev-python/stripe: Remove old (diff)
downloadgentoo-552dbafd02e83465ee91c03306da41ec28618179.tar.gz
gentoo-552dbafd02e83465ee91c03306da41ec28618179.tar.bz2
gentoo-552dbafd02e83465ee91c03306da41ec28618179.zip
dev-python/indexed_gzip: Fix build failure w/ clean command
Remove the custom "clean" command that does not implement "-a" option as used by the old distutils-r1 code path, in order to fix the build failure. This is only needed temporarily, as the new code path no longer calls it. Closes: https://bugs.gentoo.org/838955 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.6.13.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.6.13.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.6.13.ebuild
index 71ce12536dee..dff40b18267e 100644
--- a/dev-python/indexed_gzip/indexed_gzip-1.6.13.ebuild
+++ b/dev-python/indexed_gzip/indexed_gzip-1.6.13.ebuild
@@ -37,6 +37,14 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # strip custom "clean" command that doesn't support "-a"
+ # https://bugs.gentoo.org/838955
+ # TODO: this can be removed once distutils-r1 stops using clean
+ sed -i -e '/cmdclass/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
src_compile() {
if use test; then
export INDEXED_GZIP_TESTING=1