summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 13:39:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 23:32:51 +0200
commita2bdd75209cfe514c3ef832d1c068f97b2941620 (patch)
tree76c0c51eeedf42b3cdd02d171be6cdfa13888cee /dev-python/iniparse/iniparse-0.5.ebuild
parentdev-cpp/eigen: 3.3.8 version bump (diff)
downloadgentoo-a2bdd75209cfe514c3ef832d1c068f97b2941620.tar.gz
gentoo-a2bdd75209cfe514c3ef832d1c068f97b2941620.tar.bz2
gentoo-a2bdd75209cfe514c3ef832d1c068f97b2941620.zip
dev-python/iniparse: 0.5 version bump, python3_9, tests pass
Bug: https://bugs.gentoo.org/645376 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/iniparse/iniparse-0.5.ebuild')
-rw-r--r--dev-python/iniparse/iniparse-0.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/iniparse/iniparse-0.5.ebuild b/dev-python/iniparse/iniparse-0.5.ebuild
new file mode 100644
index 000000000000..f916d7a5feb9
--- /dev/null
+++ b/dev-python/iniparse/iniparse-0.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Better INI parser for Python"
+HOMEPAGE="https://pypi.org/project/iniparse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die
+}