summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-03 11:56:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-03 14:04:44 +0200
commit21b3ab493357483e6b0e185ef0572f3013769236 (patch)
tree6e0d79dbf8f658d595b2cb05883d6ade6125f599 /dev-python/ipywidgets/ipywidgets-8.0.2.ebuild
parentdev-python/dask: Bump to 2022.9.0 (diff)
downloadgentoo-21b3ab493357483e6b0e185ef0572f3013769236.tar.gz
gentoo-21b3ab493357483e6b0e185ef0572f3013769236.tar.bz2
gentoo-21b3ab493357483e6b0e185ef0572f3013769236.zip
dev-python/ipywidgets: Bump to 8.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets/ipywidgets-8.0.2.ebuild')
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-8.0.2.ebuild b/dev-python/ipywidgets/ipywidgets-8.0.2.ebuild
new file mode 100644
index 000000000000..1067cdc66e26
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.py || die
+ distutils-r1_src_prepare
+}