summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-23 09:29:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-23 09:52:44 +0100
commitd24cc7c35ea77bf6e27b7f5a44f6126e735856db (patch)
tree15b5aec0f5861cdb1b3a6c3526d419ecfabe941a /dev-python/ipywidgets
parentdev-python/json-rpc: Bump to 1.14.0 (diff)
downloadgentoo-d24cc7c35ea77bf6e27b7f5a44f6126e735856db.tar.gz
gentoo-d24cc7c35ea77bf6e27b7f5a44f6126e735856db.tar.bz2
gentoo-d24cc7c35ea77bf6e27b7f5a44f6126e735856db.zip
dev-python/ipywidgets: Bump to 8.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.0.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 8917ffa7f191..079ef28c7014 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,2 +1,3 @@
DIST ipywidgets-8.0.2.tar.gz 112516 BLAKE2B 85af0099fbbd3344e7e7985770a3dd60a5acd9dc048a274f3401e0ba6e28ff9f30405d1c32297e9b9dc004e617b26aad3f4f881d25804a9d2178f90ed2eb1c14 SHA512 45726027c68cbb6647813ba5be9e2192e63a9d80dd69246b516fef32fa0822b6cbc76d2a0622211a24fb46082c5aebcc620ece687f593077740913deaa69ceda
DIST ipywidgets-8.0.3.tar.gz 114801 BLAKE2B 759e799d10960830af8f4673dd4ee48e5528d9a0cebdde73e5e70fa764a76e0218a71178cf8812ada98b252dac785d85f7c303b7d07e47751b5d0dc42a7b04be SHA512 0448df2779361f256fc40c7dfc27572529d249a0d7fd5c77532457fc31f08dd663cf5ddca040591373b0cdb07fab99eceec8553de1d5f0a7ea726b5af9573785
+DIST ipywidgets-8.0.4.tar.gz 114780 BLAKE2B c29c431f6ba576b96792700ba325665be682f8263938dfb6e5f2c727bcdb059ed7f2997cf68ec4d76c636e99d1010b16779377a717b466005743a0fa85a2ac3a SHA512 74bdbcd7406b3a9a968842859de345c024cadc0fad3758bc02298c67d2f7b6c99c5130949a9817bf9d43f4b002c5207732dd1a42792b9ef8fceb57c36a228727
diff --git a/dev-python/ipywidgets/ipywidgets-8.0.4.ebuild b/dev-python/ipywidgets/ipywidgets-8.0.4.ebuild
new file mode 100644
index 000000000000..894ccd8541f2
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.cfg || die
+ distutils-r1_src_prepare
+}