summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-02 08:47:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-02 11:59:13 +0100
commit723f2b2adf4e2fd38f64c787f93a9a34091edcc4 (patch)
treecaf3a60a0578103b1666349eaa6c3726d5d7c7fb /dev-python/irc
parentdev-python/keyring: Bump to 23.5.0 (diff)
downloadgentoo-723f2b2adf4e2fd38f64c787f93a9a34091edcc4.tar.gz
gentoo-723f2b2adf4e2fd38f64c787f93a9a34091edcc4.tar.bz2
gentoo-723f2b2adf4e2fd38f64c787f93a9a34091edcc4.zip
dev-python/irc: Bump to 20.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-20.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index 615eb6d148f9..d2fb3fcb653e 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1 +1,2 @@
DIST irc-19.0.1.tar.gz 118227 BLAKE2B 7cafeaee39545ea2fb2257ca2ea89ccb90ed6d6607be27dac6d72cd9fc2e308a7980cc89ff4e1a491e52b071f3b91f6a56f56c9956d35f10a3bac95f214fee10 SHA512 f472c47c3fb54fd012fe16774cf19d43e07cfbc314347b02a280b6bf1d08eda9cbc13d4e3adf3af5f22b31d41e7160c44dbde9479abed01e0b5224f23ec9a0d7
+DIST irc-20.0.0.tar.gz 88662 BLAKE2B 627354a051964e53322484c8a2c28487e25738b21c485121589af331e2da59b80c5704ef4268ff0bac3e84d26f77af031ba6ce0064a46496e846c7160462a5f9 SHA512 cd54e20075e97d7c8259275514741f9bb2f93712b1cc8628399fb7d4b37ff7d1d6515be14f5326fa30e59f49cfb853b954f4f095b4d3cac870a63a9946cfbed2
diff --git a/dev-python/irc/irc-20.0.0.ebuild b/dev-python/irc/irc-20.0.0.ebuild
new file mode 100644
index 000000000000..2c4b74a481f1
--- /dev/null
+++ b/dev-python/irc/irc-20.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="https://github.com/jaraco/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
+ dev-python/jaraco-logging[${PYTHON_USEDEP}]
+ dev-python/jaraco-stream[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ dodoc -r scripts
+ fi
+ distutils-r1_python_install_all
+}