summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-22 23:32:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-23 00:04:22 +0100
commitf3666e024b19b8b9780be139fc3ef7c29bb6c945 (patch)
treee8ba63bb06fdcce60119a87e038fa23e68888d4f /dev-python/iso8601/iso8601-1.0.1.ebuild
parentdev-python/rope: Bump to 0.22.0 (diff)
downloadgentoo-f3666e024b19b8b9780be139fc3ef7c29bb6c945.tar.gz
gentoo-f3666e024b19b8b9780be139fc3ef7c29bb6c945.tar.bz2
gentoo-f3666e024b19b8b9780be139fc3ef7c29bb6c945.zip
dev-python/iso8601: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iso8601/iso8601-1.0.1.ebuild')
-rw-r--r--dev-python/iso8601/iso8601-1.0.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/iso8601/iso8601-1.0.1.ebuild b/dev-python/iso8601/iso8601-1.0.1.ebuild
new file mode 100644
index 000000000000..accfc1c9ab60
--- /dev/null
+++ b/dev-python/iso8601/iso8601-1.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="https://pypi.org/project/iso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris"
+
+distutils_enable_tests pytest