summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-14 14:17:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-14 14:57:58 +0100
commitc4c067b433f7a925983700f87ff43189364909c1 (patch)
tree164f2930ecd681c8bfe3cfbb6af35af4d9ec0065 /dev-python/isort
parentdev-python/zeroconf: Bump to 0.129.0 (diff)
downloadgentoo-c4c067b433f7a925983700f87ff43189364909c1.tar.gz
gentoo-c4c067b433f7a925983700f87ff43189364909c1.tar.bz2
gentoo-c4c067b433f7a925983700f87ff43189364909c1.zip
dev-python/isort: Bump to 5.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest1
-rw-r--r--dev-python/isort/isort-5.13.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index b0354b09e387..268effa60bae 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,4 @@
DIST isort-5.12.0.gh.tar.gz 743141 BLAKE2B a7f8deef02b57162eebe15b35e71382c654372a80dedba7eee63d0c9b0899c053fb517401585af17014db3cf9ed44089f6cbd1e2b0ed17393cc667de06bfbddd SHA512 ceb861d1a077be6fecd82fde775bded1fb676c77135e2004c92a6221762e0b3ff6c1071d17957e1add4062ec26ba6c9264e4905724f2c659339cbd0601f4b45e
DIST isort-5.13.0.gh.tar.gz 753826 BLAKE2B 074e8b762b304618a2291d96dc9e18061e5303f3e6772479e8eda42c687cf289c12c73ce585c869df754b244bf14d59c6d2eba10877756287d88f27a3d470939 SHA512 3c5a170b1526ec58f1c774e4b55e2227df0af23eebd7a387d61cd3eaa0a698b5ad22a0be81a87d4e6a026030ffbdaea0f23331a43e28b5df98bf33b7afe2a42d
DIST isort-5.13.1.gh.tar.gz 754890 BLAKE2B 53168670d38efa9fba549a32235c47781e200e7ee36289514acc19b127fa5a99d9d97305fbeff1afa9dd6f8f57385f0b01ce57b4bd0ee64e255bcfe144fadbbf SHA512 23a5f7579e327f109575454e5443ee039c207aa0b6f6ad35509cf514b45a7a3fcae116fd8ee40c96d717694cfd85bd7f431481b1a456b7390f914abec2460f42
+DIST isort-5.13.2.gh.tar.gz 755256 BLAKE2B 4cc8a0209ba954d93c030e6ad038933b50aa2f17b173762f598bc8038f36f72ecd1e7a3f6e73398bbfc99f464d14927f77044ca68126815023a8d456497985a1 SHA512 fe2bd27f0aa6219d44c3124782d400338a801a911d6a09ad51e7f80cbcbce250838350ad6cc80a35f641e0a319778ddcfb4dc61c8c76999ebc63a5147953e378
diff --git a/dev-python/isort/isort-5.13.2.ebuild b/dev-python/isort/isort-5.13.2.ebuild
new file mode 100644
index 000000000000..2f75471007a0
--- /dev/null
+++ b/dev-python/isort/isort-5.13.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="
+ https://github.com/PyCQA/isort/
+ https://pypi.org/project/isort/
+"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle tomli
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+
+ if ! has_version "dev-python/pylama[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/unit/test_importable.py
+ tests/unit/test_pylama_isort.py
+ )
+ fi
+
+ epytest tests/unit
+}