summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-10 07:16:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-10 07:30:13 +0200
commit92198f7f015b1aab6398e984676ee2d59f3247c1 (patch)
treeb18bc7155b0b2944ae15b94720a508c40d5fa0b0 /dev-python/jaraco-path/jaraco-path-3.5.0.ebuild
parentdev-python/pytest-describe: Bump to 2.1.0 (diff)
downloadgentoo-92198f7f015b1aab6398e984676ee2d59f3247c1.tar.gz
gentoo-92198f7f015b1aab6398e984676ee2d59f3247c1.tar.bz2
gentoo-92198f7f015b1aab6398e984676ee2d59f3247c1.zip
dev-python/jaraco-path: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-path/jaraco-path-3.5.0.ebuild')
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/jaraco-path-3.5.0.ebuild b/dev-python/jaraco-path/jaraco-path-3.5.0.ebuild
new file mode 100644
index 000000000000..603bf9bb1af4
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}