summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jsonmerge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jsonmerge')
-rw-r--r--dev-python/jsonmerge/Manifest1
-rw-r--r--dev-python/jsonmerge/jsonmerge-1.1.0.ebuild26
-rw-r--r--dev-python/jsonmerge/metadata.xml12
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jsonmerge/Manifest b/dev-python/jsonmerge/Manifest
new file mode 100644
index 000000000000..d8611c680f87
--- /dev/null
+++ b/dev-python/jsonmerge/Manifest
@@ -0,0 +1 @@
+DIST jsonmerge-1.1.0.tar.gz 12556 SHA256 2ae73a058474e75f27d4ac2595d9da28084ae42be506f04d077ccea3a853b921 SHA512 52ca9d17098533ada09365caddaaa92b0e0ac696c99b92db6aabc8942183a6d9e06ebf002213d8cebbd25d4905a6a7bfa17ad9d296c838b0019b9f30e403ce94 WHIRLPOOL 610597ffb82cc1cf92d40e2c54fe4877c6e38431611855328a6dba5246f2e12420cf7994e00b296a7880588cc4976df62e359e78b6402ec74275d4f343d8618a
diff --git a/dev-python/jsonmerge/jsonmerge-1.1.0.ebuild b/dev-python/jsonmerge/jsonmerge-1.1.0.ebuild
new file mode 100644
index 000000000000..bcd01c68b3d6
--- /dev/null
+++ b/dev-python/jsonmerge/jsonmerge-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Merge a series of JSON documents."
+HOMEPAGE="https://github.com/omergertel/jsonmerge/ https://pypi.python.org/pypi/jsonmerge/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${REPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH="${PWD}" python -m unittest \
+ $(find tests -name 'test_*.py' | LC_ALL=C sort | sed -e 's:/:.:' -e 's:.py$::') || die
+}
diff --git a/dev-python/jsonmerge/metadata.xml b/dev-python/jsonmerge/metadata.xml
new file mode 100644
index 000000000000..890e2ec8780a
--- /dev/null
+++ b/dev-python/jsonmerge/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">jsonmerge</remote-id>
+ <remote-id type="github">omergertel/jsonmerge</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+</pkgmetadata>