summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 21:07:29 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 21:07:38 +0100
commit68cc98b1deec57c746649bca95159eec42ebf950 (patch)
tree282403ec63b262ff639fb7267a6ecf9a8fcaf882 /dev-python/jsonpointer/jsonpointer-1.10.ebuild
parentdev-python/jsonpatch: Bump (diff)
downloadgentoo-68cc98b1deec57c746649bca95159eec42ebf950.tar.gz
gentoo-68cc98b1deec57c746649bca95159eec42ebf950.tar.bz2
gentoo-68cc98b1deec57c746649bca95159eec42ebf950.zip
dev-python/jsonpointer: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-1.10.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-1.10.ebuild b/dev-python/jsonpointer/jsonpointer-1.10.ebuild
new file mode 100644
index 000000000000..0c784a0711d2
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}