summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 13:50:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 14:08:53 +0200
commit85753b3858bad96501fffc8ee06627eaa683c96e (patch)
treebd5888b5a4f25488df3dc6b51be95a2574d409ac /dev-python/jsonref
parentdev-python/installer: Bump to 0.5.1 (diff)
downloadgentoo-85753b3858bad96501fffc8ee06627eaa683c96e.tar.gz
gentoo-85753b3858bad96501fffc8ee06627eaa683c96e.tar.bz2
gentoo-85753b3858bad96501fffc8ee06627eaa683c96e.zip
dev-python/jsonref: Bump to 0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonref')
-rw-r--r--dev-python/jsonref/Manifest1
-rw-r--r--dev-python/jsonref/jsonref-0.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jsonref/Manifest b/dev-python/jsonref/Manifest
index 7616822e2725..d4c5f01fc21a 100644
--- a/dev-python/jsonref/Manifest
+++ b/dev-python/jsonref/Manifest
@@ -1 +1,2 @@
DIST jsonref-0.1.tar.gz 12296 BLAKE2B cab2b4778b8a0184989ed6ff520ed6f12a68e9109a92aa0fd5521b69ea14cd5b6301ce61bf98f0d0d4d44fb016f7d6bd99fc804975bddf1c350bc4b46d62f77f SHA512 9900601feab0c20c902a6d5575fd411898af126a650d0c9ff955f50f5bd1f5da8e5a071ca86cac31ce3c5fb35a516f849cbb70098cac2cfdc910ba33a1f7411b
+DIST jsonref-0.2.tar.gz 13032 BLAKE2B 0db36904f6914c889d608ac6a368cc8a80b0f81b6bf9f77bb229042c484084c6a06f31099440a48f49f5efea248e0e4f498269bdf89e240be8e149a0f221747d SHA512 415eaefcaf2c7a02bf70749522fef0d96f1e0cc5772edd50ca016a564258df21dd3eb178b7a33ee61e606125fb802a29b0cb8855a81c6116baf6393208927b0f
diff --git a/dev-python/jsonref/jsonref-0.2.ebuild b/dev-python/jsonref/jsonref-0.2.ebuild
new file mode 100644
index 000000000000..84fdd34cbed9
--- /dev/null
+++ b/dev-python/jsonref/jsonref-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON Reference for Python"
+HOMEPAGE="
+ https://github.com/gazpachoking/jsonref/
+ https://pypi.org/project/jsonref/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}