summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 19:45:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 19:51:13 +0200
commit8b1c0df316da8694b98099f9520c1c542e4f3c96 (patch)
treeae8a10ae17953d0dd8a73dcbaa017199c1252607 /dev-python/jupyter-events
parentdev-python/kerberos: Enable py3.12 (diff)
downloadgentoo-8b1c0df316da8694b98099f9520c1c542e4f3c96.tar.gz
gentoo-8b1c0df316da8694b98099f9520c1c542e4f3c96.tar.bz2
gentoo-8b1c0df316da8694b98099f9520c1c542e4f3c96.zip
dev-python/jupyter-events: Enable py3.12 in 0.6.3
TODO: we need to remove it, and wd40 all revdeps, sigh. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-events')
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.6.3.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild b/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
index 01ada11cc180..2b3db8655ef1 100644
--- a/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
+++ b/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -38,3 +38,18 @@ BDEPEND="
# TODO: package jupyterlite-sphinx
# distutils_enable_sphinx docs
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_logger.py::test_emit
+ tests/test_logger.py::test_unique_logger_instances
+ )
+ ;;
+ esac
+
+ epytest
+}