summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 23:39:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 23:53:24 +0200
commit1c7d7f683ed46b4925728f131f47724e96b5cf08 (patch)
treef574cc469b9d39850fbd1eee7b896dcc830ff0bc /dev-python/jupyter_client
parentapp-admin/awscli: Bump to 1.20.25 (diff)
downloadgentoo-1c7d7f683ed46b4925728f131f47724e96b5cf08.tar.gz
gentoo-1c7d7f683ed46b4925728f131f47724e96b5cf08.tar.bz2
gentoo-1c7d7f683ed46b4925728f131f47724e96b5cf08.zip
dev-python/jupyter_client: Bump to 7.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index aeab6a212aa7..c085884a134e 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-6.1.12.tar.gz 301499 BLAKE2B 8041b84ad2e89413ee60d1aee2e49a67a89b5aad1c3118c8fa7d7d719c8ec2acbc72278c9aaea095cdcb89235800d09b1792b2138c09a4aad59ceaaf695af431 SHA512 f31ff1a24b264c32d35d07491785e1d77935cdb463243e90e4aadcb0a093a074cdce75f01662591766588f39b146077639ca697f71157309dc92f12ae04d5cdd
+DIST jupyter_client-7.0.0.tar.gz 317271 BLAKE2B 446b0b5dfea840a2faf25445217d870654836cd1e63057d9fb8e596960da1528684ec51b452d1059ab83317ff9da3c65cf5c8b14c3f2cfbba7dbcfdeec0e31b5 SHA512 dadcd06a4c63e441c60edc9fb8ed49d14a1309822042d7f8cbc48943d394da720117ca829fe38e419f775025cdb01227e47f077f89f8ce5403efbeb1a1d1ef2c
diff --git a/dev-python/jupyter_client/jupyter_client-7.0.0.ebuild b/dev-python/jupyter_client/jupyter_client-7.0.0.ebuild
new file mode 100644
index 000000000000..1cd1c8e4bf38
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.1[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest