summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 23:48:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 23:48:58 +0100
commit99fcd840ef6c9b0173e8c1a55f5202f232ca8a4f (patch)
treeb29d980611e50336c8aae187694200b51c4acf99 /dev-python/jupyter_core
parentdev-python/croniter: Bump to 1.3.1 (diff)
downloadgentoo-99fcd840ef6c9b0173e8c1a55f5202f232ca8a4f.tar.gz
gentoo-99fcd840ef6c9b0173e8c1a55f5202f232ca8a4f.tar.bz2
gentoo-99fcd840ef6c9b0173e8c1a55f5202f232ca8a4f.zip
dev-python/jupyter_core: Bump to 4.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.9.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index bf71a02a74b8..cebd4b97c8ad 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.9.1.tar.gz 74787 BLAKE2B 3c902063c4d2819c8254eca87a64d922c3d1e408fc22e96d03765a8bb0fe644a9aafaccf3db106841becf307ffe47c9fcb723cad611833b5fcbe79e812ea2445 SHA512 3a176271e073448e3a15a69d51558486775abebec051e141594fe0d2859d9a0fc5cadbf6857764de6d1ec746f03d9d22419c91f97015d4ff6694626f455df773
+DIST jupyter_core-4.9.2.tar.gz 74912 BLAKE2B 9a20e7982d1bda6a203f094aca6ebaa2b96d0482d728527b1b085b1242c94fb407d7f9da3e82c3e2af473c725bc7bebe701d493a201d8804c3d7aae9f80f9c11 SHA512 2779d7857b3efb979df29f65e5db0a625e4c96b1bbed017aa7bdaa7d23d7cb202d745c92db663a183bdcdc5f55133aa32bc6c982d5a9d36decceb9a348e7754b
diff --git a/dev-python/jupyter_core/jupyter_core-4.9.2.ebuild b/dev-python/jupyter_core/jupyter_core-4.9.2.ebuild
new file mode 100644
index 000000000000..b2bc158885ce
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest