summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-03 08:48:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-03 09:51:34 +0200
commita63d05f0f6f4e9fe1e7025330197ee2592d2ec5b (patch)
treeb29cb8215885f1236309ac7a8063e85a29902667 /dev-python/klein/klein-23.5.0.ebuild
parentdev-python/lmfit: Bump to 1.2.1 (diff)
downloadgentoo-a63d05f0f6f4e9fe1e7025330197ee2592d2ec5b.tar.gz
gentoo-a63d05f0f6f4e9fe1e7025330197ee2592d2ec5b.tar.bz2
gentoo-a63d05f0f6f4e9fe1e7025330197ee2592d2ec5b.zip
dev-python/klein: Bump to 23.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/klein/klein-23.5.0.ebuild')
-rw-r--r--dev-python/klein/klein-23.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/klein/klein-23.5.0.ebuild b/dev-python/klein/klein-23.5.0.ebuild
new file mode 100644
index 000000000000..115b81d4d0d5
--- /dev/null
+++ b/dev-python/klein/klein-23.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Micro-framework for developing production-ready web services with Python"
+HOMEPAGE="
+ https://pypi.org/project/klein/
+ https://github.com/twisted/klein/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ dev-python/hyperlink[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/tubes[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.6[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/treq[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest