summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-10 22:03:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-10 22:17:32 -0600
commit2b7c6f4ba3673cc925db522681dd6e60afaa6d64 (patch)
treeb37d545ce62fac1bf18360575055ccf1e2e4797d /dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
parentapp-emulation/libvirt: Simplify dep to avoid accidental downgrade (diff)
downloadgentoo-2b7c6f4ba3673cc925db522681dd6e60afaa6d64.tar.gz
gentoo-2b7c6f4ba3673cc925db522681dd6e60afaa6d64.tar.bz2
gentoo-2b7c6f4ba3673cc925db522681dd6e60afaa6d64.zip
dev-python/lazr-delegates: dding for lazr-config for mailman 3
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild')
-rw-r--r--dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
new file mode 100644
index 000000000000..91b3d11ee686
--- /dev/null
+++ b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Easily write objects that delegate behavior"
+HOMEPAGE="https://code.launchpad.net/lazr.deletages"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]"