summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-06 19:51:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-06 20:00:06 +0300
commit6da51569d8f8c20188dbc13a82a2f136e1429e41 (patch)
tree1602871c22c9f3819cf6aee6258a642064908e2b /dev-python/leechcorepyc
parentdev-python/plumbum: add 1.8.0 (diff)
downloadgentoo-6da51569d8f8c20188dbc13a82a2f136e1429e41.tar.gz
gentoo-6da51569d8f8c20188dbc13a82a2f136e1429e41.tar.bz2
gentoo-6da51569d8f8c20188dbc13a82a2f136e1429e41.zip
dev-python/leechcorepyc: add 2.13.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/leechcorepyc')
-rw-r--r--dev-python/leechcorepyc/Manifest1
-rw-r--r--dev-python/leechcorepyc/leechcorepyc-2.13.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/leechcorepyc/Manifest b/dev-python/leechcorepyc/Manifest
index ecac8d5c6807..161857fa2b43 100644
--- a/dev-python/leechcorepyc/Manifest
+++ b/dev-python/leechcorepyc/Manifest
@@ -1,2 +1,3 @@
DIST leechcorepyc-2.12.0.tar.gz 120774 BLAKE2B 7e7de1388acb73bb391ae5451c5b4f3f4b6c4891a1c420f2d662c930a37d4db702731c70861d8467b82b4e29dc1c22560215b1f8fe9ec8f7675fe69b63844ae3 SHA512 bb8c4c76ab8ec610f8c879c75dbed36006b16a165c20ac17ccd8a8978e1e0b4f5543c8aa8b054ea4cf58d38e908e8b92ba13898697c2465776add1bc964762b1
DIST leechcorepyc-2.12.1.tar.gz 120816 BLAKE2B b9af01e7544c0c77105435bd49d633c182e91788035a56747fef7ed860cc3570e766b038d5445df8e9d2df6e81a47a133af290b7c45db729eec7a0e46d8a0f38 SHA512 b2c3eb32bd5727839fe3ead1d5d123be4abc7b96deb71897461c3a559994ff7d6d26e3b1b857f119b8003023efa619c01073082046eb9fb105f8a8627b49d6db
+DIST leechcorepyc-2.13.0.tar.gz 123152 BLAKE2B 8a3ae5b0f0d52296ef71bbbea5140f9dec6abd379ae2a1b0e3a418090a11e5196731b1c4cba5320d4058c562911366cc9dd84f3a30f58ddc7c66362a9b39af8f SHA512 1420f635bebafe1e07cb5f0ade3e6b141433d4a72ec165713f959dc19e05f42a86440c5c99dd5d759aee221ee478e91e7161541cebe11be6dfa286fad79843ae
diff --git a/dev-python/leechcorepyc/leechcorepyc-2.13.0.ebuild b/dev-python/leechcorepyc/leechcorepyc-2.13.0.ebuild
new file mode 100644
index 000000000000..25fcfee44ade
--- /dev/null
+++ b/dev-python/leechcorepyc/leechcorepyc-2.13.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Python binding for LeechCore Physical Memory Acquisition Library"
+HOMEPAGE="https://github.com/ufrisk/LeechCore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# leechcorepyc ships with a bundled version of the LeechCore library. So we
+# don't depend on the library here. But we must be aware this module doesn't
+# use the system library.
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.12.0-respect-CC.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ distutils-r1_src_configure
+}