summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-31 23:16:14 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-04-01 23:53:22 +0200
commit9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9 (patch)
treeb9d7e529559c2e8908d71a12d3a9a49e7086f124 /dev-python/lesscpy/lesscpy-0.13.0.ebuild
parentmedia-libs/libdvbpsi: stable 1.3.1 for ppc64, bug #648058 (diff)
downloadgentoo-9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9.tar.gz
gentoo-9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9.tar.bz2
gentoo-9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9.zip
dev-python/lesscpy: version bump.
Closes: https://bugs.gentoo.org/634018 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/lesscpy/lesscpy-0.13.0.ebuild')
-rw-r--r--dev-python/lesscpy/lesscpy-0.13.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/lesscpy/lesscpy-0.13.0.ebuild b/dev-python/lesscpy/lesscpy-0.13.0.ebuild
new file mode 100644
index 000000000000..fe7989aca099
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+# incomplete tarball
+RESTRICT="test"
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ # https://github.com/lesscpy/lesscpy/issues/74
+ esetup.py test
+ # This is equally effective
+ # nosetests -v || die "tests failed under ${EPYTHON}"
+}