summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-06-01 14:05:20 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-06-01 14:11:16 -0700
commitcb9cd98e78ccf0f8231b89e023877fa3f5dbbd0c (patch)
treeeb7703da912567757bcd5a6ddcd197850314194d /dev-python/libtmux/libtmux-0.22.1.ebuild
parentsys-fs/lvm2: Stabilize 2.03.21 arm64, #907477 (diff)
downloadgentoo-cb9cd98e78ccf0f8231b89e023877fa3f5dbbd0c.tar.gz
gentoo-cb9cd98e78ccf0f8231b89e023877fa3f5dbbd0c.tar.bz2
gentoo-cb9cd98e78ccf0f8231b89e023877fa3f5dbbd0c.zip
dev-python/libtmux: add 0.22.1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/libtmux/libtmux-0.22.1.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.22.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/libtmux/libtmux-0.22.1.ebuild b/dev-python/libtmux/libtmux-0.22.1.ebuild
new file mode 100644
index 000000000000..499498389f30
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.22.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for tmux"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+)
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ sed -e '/addopts/s:--doctest-docutils-modules::' \
+ -e '/README\.md/d' \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}