summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-14 17:35:34 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-14 17:35:34 -0800
commit2762c28d5757c26d79e77f0ceb8f57dd112a5eca (patch)
tree7227d9764fee46b19e905c701ab684c5eeaa789b /dev-python/libtmux
parentdev-util/shellcheck-bin: adjust ebuild style (diff)
downloadgentoo-2762c28d5757c26d79e77f0ceb8f57dd112a5eca.tar.gz
gentoo-2762c28d5757c26d79e77f0ceb8f57dd112a5eca.tar.bz2
gentoo-2762c28d5757c26d79e77f0ceb8f57dd112a5eca.zip
dev-python/libtmux: add 0.28.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.28.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 737201039911..6babe596cfcb 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -6,3 +6,4 @@ DIST libtmux-0.24.1.gh.tar.gz 265873 BLAKE2B 4dbc6ef078ed2fb83115b54b2b78b2076a0
DIST libtmux-0.25.0.gh.tar.gz 268260 BLAKE2B ac9da378491acbb91eb8e67e47ef213206d77f618a35fd6cba1014435c70b82eca712f764ccc4f2fa14f4027001678e31743ade9b28ffbc9e5509e2592afab48 SHA512 72cf2a24af0407baa775f1be13490c45b573cfaabc6803b57d77cc0eac5de0ef9b8c3a8923437163d1b6b9486a86b71076df40761f302d3534d36d94c68bd6bb
DIST libtmux-0.26.0.gh.tar.gz 268056 BLAKE2B c89424babf8a1af34aa1e5766982f909fbd5cbad44c6536a49bb03a531d0c0ca30d9e088d003606275a453b419c718ec84bb4b9638c73127b21ac9ffada925d6 SHA512 48d3a56045bbb3920db9ab15f9dcbbe56e3b37ac1e12834cab4ea2d42ac51fe563a6dd340f8b6109674b20d8ad3cd6551d10cb643f660a6523af66fc67b100b2
DIST libtmux-0.27.0.gh.tar.gz 270128 BLAKE2B 330335e24ff5f1777d3a4ebd4746adcc391919a129c08c1bfe80d7ef61e962dc550690a68055390c58e8e6c539edcac74def8646d4b1055503496ac38f72fc0d SHA512 fd847524bf6b0742bac4eca2c1032e069be09081e9107a6403eebfce0f6ca4e624f717aae0794ece54065d50cc1eb6ef48327ef1e9aea794328c42a5d7bbb293
+DIST libtmux-0.28.0.gh.tar.gz 273309 BLAKE2B 9bc5b3068e64f09af0411f68f22cd23535b084175970338c827783741c8abde03548996cd573c6b58ce49298582f8e159dcab569fb6d19560229187a8da269b1 SHA512 8a6457c82cb06c72c0382c362e5d84d0a5498a01e8806adffd7e8c3a67c1b741fbd11892a3cca2156f940a954684e2d6f85ee7ad14f582f5727b977d433dd707
diff --git a/dev-python/libtmux/libtmux-0.28.0.ebuild b/dev-python/libtmux/libtmux-0.28.0.ebuild
new file mode 100644
index 000000000000..5131b7f304b5
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.28.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Typed library that provides an ORM wrapper for tmux, a terminal multiplexer"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ sed -r -e '/addopts/s:--doctest-docutils-modules::' \
+ -e '/^[[:space:]]+"README\.md"/d' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -a EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+ tests/legacy_api/test_test.py
+ )
+
+ epytest
+}