summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-01 08:41:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-01 09:21:35 +0200
commita1a8999729d8e4f7877968bf6e3e2ad3139ed98b (patch)
tree45548d3f18256bff5bd3a908614ab1c10e41b817 /dev-python/llfuse
parentdev-python/jc: Bump to 1.20.0 (diff)
downloadgentoo-a1a8999729d8e4f7877968bf6e3e2ad3139ed98b.tar.gz
gentoo-a1a8999729d8e4f7877968bf6e3e2ad3139ed98b.tar.bz2
gentoo-a1a8999729d8e4f7877968bf6e3e2ad3139ed98b.zip
dev-python/llfuse: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.4.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index cdc4ca4377a7..e7b6859f1462 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.4.1.tar.gz 774540 BLAKE2B f135ff3cde6effe72f5adf1b9ed58566183775ad45acbd1906db1f5c60a38ab74f0c7b6cda949b3ff2c4b46f036c91e16f9231ede1c78359c87758e6abde9ea4 SHA512 e94045018e9d78b7b16355dd499a27694a77a70d61102d05938223b99686e4b9d90b5e14745d92a187ac8e34aa593a12d99bff1baccb19d4236d54eb66ec3e4f
+DIST llfuse-1.4.2.tar.gz 834763 BLAKE2B 60bdfdd4567de4aa6ab5ea6692f48e6d68572bc13976e30fa9850c96b8a2c8a77638d3750df549b827a2bba0cc2dfa2a3f2cac3c4729278515a2703ecde446a1 SHA512 6a368af9e49f8537bbea396dfcd9fc024f8b93b161d3c6167d13c4ffb0ab20b6c8393447e71b5c147c82d4d1ee590ae08c512c93ccb28df78a06ab6833ac3705
diff --git a/dev-python/llfuse/llfuse-1.4.2.ebuild b/dev-python/llfuse/llfuse-1.4.2.ebuild
new file mode 100644
index 000000000000..4abb93eee3b9
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.4.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="
+ https://github.com/python-llfuse/python-llfuse/
+ https://pypi.org/project/llfuse/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # force regen
+ rm src/llfuse.c || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ! -f src/llfuse.c ]]; then
+ esetup.py build_cython
+ fi
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}