summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 17:47:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 17:55:16 +0100
commit2efe841a5d35dca116ffa2cb6d1f94a5ed731318 (patch)
treee7eb19416e921d010c5f1675100d09ae2fc949d0 /dev-python/loguru
parentdev-python/loguru: Add python@ as a maintainer (diff)
downloadgentoo-2efe841a5d35dca116ffa2cb6d1f94a5ed731318.tar.gz
gentoo-2efe841a5d35dca116ffa2cb6d1f94a5ed731318.tar.bz2
gentoo-2efe841a5d35dca116ffa2cb6d1f94a5ed731318.zip
dev-python/loguru: Bump to 0.7.2
Closes: https://bugs.gentoo.org/920653 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/loguru')
-rw-r--r--dev-python/loguru/Manifest1
-rw-r--r--dev-python/loguru/loguru-0.7.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
index 63c4e36dc3ec..ef5591fc6cd8 100644
--- a/dev-python/loguru/Manifest
+++ b/dev-python/loguru/Manifest
@@ -1 +1,2 @@
DIST loguru-0.7.0.gh.tar.gz 430544 BLAKE2B 13ee91da7c7bc0b29297cb70235c26e0517939c332dde342c14cb937112d5a0b9c467ec273f2034875a52902ffc05dd780fd349498d8a0b65efd6ecf6a947056 SHA512 02d2a0c7c54a5083a444a23222854ee4587da3f7a490ec193d0bae2f3c464c0a86102417f5886205e73c0a149694b931f39f3c5a1ade605cf2b2799395a478a0
+DIST loguru-0.7.2.gh.tar.gz 443643 BLAKE2B 208c4ad989257e0e0d5cecf41c9722f398e5c73528f8a88c92e28490121723d5c19b4170ff246446e94237e8bb732f83e4b9fcc66c42aa7e3c1ba25aaa069e34 SHA512 e4d358f12ec33393bdac836206a15a3161653684b69839f58bbdc692155e4aee4b6ec700ab13b83f431a67df5ec86cacf2cb90fa052827e5e03c68c1f132e339
diff --git a/dev-python/loguru/loguru-0.7.2.ebuild b/dev-python/loguru/loguru-0.7.2.ebuild
new file mode 100644
index 000000000000..d9945b466f62
--- /dev/null
+++ b/dev-python/loguru/loguru-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="
+ https://github.com/Delgan/loguru/
+ https://pypi.org/project/loguru/
+"
+SRC_URI="
+ https://github.com/Delgan/loguru/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.2.2[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ )
+"
+
+# filesystem buffering tests may fail
+# on tmpfs with 64k PAGESZ, but pass fine on ext4
+distutils_enable_tests pytest