summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-10 06:21:47 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-10 07:03:16 +0200
commit4f95767ffa5103ec45e974496c6d4613ec0acea3 (patch)
tree5bdc830e23d4bc9e3337b8674577fa44bc993377 /dev-python/lxml-html-clean
parentdev-python/simsimd: Bump to 5.6.4 (diff)
downloadgentoo-4f95767ffa5103ec45e974496c6d4613ec0acea3.tar.gz
gentoo-4f95767ffa5103ec45e974496c6d4613ec0acea3.tar.bz2
gentoo-4f95767ffa5103ec45e974496c6d4613ec0acea3.zip
dev-python/lxml-html-clean: Bump to 0.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lxml-html-clean')
-rw-r--r--dev-python/lxml-html-clean/Manifest1
-rw-r--r--dev-python/lxml-html-clean/lxml-html-clean-0.3.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/lxml-html-clean/Manifest b/dev-python/lxml-html-clean/Manifest
index ac94dcb4bff5..e770187627ea 100644
--- a/dev-python/lxml-html-clean/Manifest
+++ b/dev-python/lxml-html-clean/Manifest
@@ -1 +1,2 @@
DIST lxml_html_clean-0.2.2.tar.gz 19619 BLAKE2B 4317ba3e3ae05603f5e2e53561ea7bf2c2d291ac7c87eb2d4afeaca89ccb13b63dd4a85c9a9e4d5feb3bc6773d27618d2057983b933b3b17e26c319003b3bb7c SHA512 c40aac3453e822c5659252a271071b1e3b61622ce3af78e27763c771147a22a9894ef2512ca38f1d0e67be1d21ce5b860641a2a067e94837cfdcb318610720eb
+DIST lxml_html_clean-0.3.1.tar.gz 20851 BLAKE2B 476c73463341af064e7d32b4def1b3cbbc7287cb26308fed2362792ce9dfc3c20bdbb9dcc1174710bf694633789037ec4f1c2510c48fab98ba17fb506b091baa SHA512 cbbcbec337586024db9b622d5724adc1e645dfe7bb1958be8f8974c7858e9a6443b0e75f09cf0ca83d7331aae944648c6bd644aeedd56307a01269e82d866b36
diff --git a/dev-python/lxml-html-clean/lxml-html-clean-0.3.1.ebuild b/dev-python/lxml-html-clean/lxml-html-clean-0.3.1.ebuild
new file mode 100644
index 000000000000..8523f79facae
--- /dev/null
+++ b/dev-python/lxml-html-clean/lxml-html-clean-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Separate project for HTML cleaning functionalities copied from lxml.html.clean"
+HOMEPAGE="
+ https://github.com/fedora-python/lxml_html_clean/
+ https://pypi.org/project/lxml-html-clean/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/lxml-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest
+ "${EPYTHON}" -m doctest -v tests/*.txt ||
+ die "Doctests failed on ${EPYTHON}"
+}