summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-22 06:19:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-22 07:47:59 +0200
commit6ca0e6dd827c2c8ffc2a91f484fcb6aea42afcf5 (patch)
treec0ce399811b7b3f80dcdeb5d7578f595c0209a58 /dev-python/makefun
parentapp-admin/awscli: Bump to 1.25.14 (diff)
downloadgentoo-6ca0e6dd827c2c8ffc2a91f484fcb6aea42afcf5.tar.gz
gentoo-6ca0e6dd827c2c8ffc2a91f484fcb6aea42afcf5.tar.bz2
gentoo-6ca0e6dd827c2c8ffc2a91f484fcb6aea42afcf5.zip
dev-python/makefun: Bump to 1.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/makefun')
-rw-r--r--dev-python/makefun/Manifest1
-rw-r--r--dev-python/makefun/makefun-1.14.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
index e64a9b497cde..1e449426b362 100644
--- a/dev-python/makefun/Manifest
+++ b/dev-python/makefun/Manifest
@@ -1 +1,2 @@
DIST makefun-1.13.1.tar.gz 72170 BLAKE2B b1b5e76277e742ef51bcdf2bf6f1d1e761010d75bc3f20d7a8c079b368972b90775bd3bb23cf1787911a8d858549d72d4a2c9379675e59f359486bf1c49566e2 SHA512 ae103d3827673c4124d051e3c76d3d0d126c783ac7a1ea09de3801fd695439eaa549c297bd5c262184a3ee6fdf7b046065081fa3183642778148c2134d7bfc06
+DIST makefun-1.14.0.tar.gz 73792 BLAKE2B 8a3f947d53787efc1be6d76c4c817063a21d0e135815d196988aa2c6d1e0998344010dfd1e2f33f31c0d47fcad8b7e4c0c7c9e408bdd3ea60f668c3ec8ae09dd SHA512 49b239a559e0ec5e28c29c210161c3530e1d89b39a22f16382f0569a47a6d696917d86c9abefb7ac6dc59f904276f8a853a2dc09b1d9c2332e422757f6eb9a08
diff --git a/dev-python/makefun/makefun-1.14.0.ebuild b/dev-python/makefun/makefun-1.14.0.ebuild
new file mode 100644
index 000000000000..56106e410e5e
--- /dev/null
+++ b/dev-python/makefun/makefun-1.14.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="
+ https://pypi.org/project/makefun/
+ https://github.com/smarie/python-makefun/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.cfg || die
+ distutils-r1_src_prepare
+}