summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-07-24 09:08:58 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:33:46 +0200
commit4b60f1b278a7521bc218e4d1af5b2881e83989f4 (patch)
tree5456dd23e724d556880c4d0b2bf624d6ca9b3904 /dev-python/matplotlib2tikz
parentx11-wm/stumpwm: use HTTPS for GitHub, fix whitespace in metadata.xml (diff)
downloadgentoo-4b60f1b278a7521bc218e4d1af5b2881e83989f4.tar.gz
gentoo-4b60f1b278a7521bc218e4d1af5b2881e83989f4.tar.bz2
gentoo-4b60f1b278a7521bc218e4d1af5b2881e83989f4.zip
dev-python/matplotlib2tikz: Version bump to 0.6.11
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5192
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch24
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild39
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 3c17d71ae82b..ac645618b005 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
+DIST matplotlib2tikz-0.6.11.tar.gz 524298 SHA256 79c9f141fd802fe5863d2eaff6c67476d02ca474433e65990c935241a2591994 SHA512 eda5042f1db35436ca56256cb858fa11b48d497f621183475d69381b0b10ac67f9447522e1b78c1a331337e34eb159b5ffeef9655a8c0dc4ccab22b7afcb5e96 WHIRLPOOL b09025b9444e0a0ec122fbb7d6d90e32e043c3a86e8b7454ac3fdc0ba03374f5648491a4564bae7ef622a536f4ec92e762a68816d64621da6df44fea2c404c8c
DIST matplotlib2tikz-0.6.7.tar.gz 523464 SHA256 ba95bbf5f654abccee6c3e9ab9bdd4e7fc6cab5d49def072d1c7a9020b7b602e SHA512 9128eb7cabcd44ed84ac5d9b125dc897d2901cd4d29a8aa6bbd48c35c6418f4b5cd5b8e7c55e7690fe927c704580fe2d83084c37d515c9a25ee67ea476a63e4d WHIRLPOOL f1cd962ebafab85adbd8bbaaf6f565e1312d610bfd7cd0827f60535432ce952ae6e5535860e754ad872cdfffaa70bb72d4cfb676adb91b2624f5ab060969fd7b
diff --git a/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch
new file mode 100644
index 000000000000..3b7cf2ffbe51
--- /dev/null
+++ b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch
@@ -0,0 +1,24 @@
+Remove version checks using pipdated.
+
+Patch by Marius Brehler <marbre@linux.sungazer.de>
+--- a/matplotlib2tikz/__init__.py
++++ b/matplotlib2tikz/__init__.py
+@@ -16,7 +16,3 @@ from matplotlib2tikz.__about__ import (
+ )
+
+ from matplotlib2tikz.save import get_tikz_code, save
+-
+-import pipdated
+-if pipdated.needs_checking(__name__):
+- print(pipdated.check(__name__, __version__))
+
+--- a/setup.py
++++ b/setup.py
+@@ -34,7 +34,6 @@ setup(
+ 'matplotlib >=1.4.0',
+ 'numpy',
+ 'Pillow >= 3.0.0',
+- 'pipdated',
+ 'six',
+ ],
+ description='convert matplotlib figures into TikZ/PGFPlots',
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild
new file mode 100644
index 000000000000..437c6ed6f555
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}/${P}-pipdated.patch" )
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}