summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mecab-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mecab-python')
-rw-r--r--dev-python/mecab-python/Manifest1
-rw-r--r--dev-python/mecab-python/files/mecab-python-py3.diff11
-rw-r--r--dev-python/mecab-python/mecab-python-0.996.ebuild24
-rw-r--r--dev-python/mecab-python/metadata.xml8
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/mecab-python/Manifest b/dev-python/mecab-python/Manifest
new file mode 100644
index 000000000000..69a93690f6e1
--- /dev/null
+++ b/dev-python/mecab-python/Manifest
@@ -0,0 +1 @@
+DIST mecab-python-0.996.tar.gz 62338 SHA256 d305c30af9e781e70f7619a0b444ac1101f2faaf3922415a0d6c49da85a63511 SHA512 08954ed801419fd7f65d055244227364bc37b063f8d21babb6ceeb02ca40e0146fa4401d1426255f3656ac1a5e51439bde981414613153dca5972f624289447e WHIRLPOOL bae9a50996fa46bc0cf70b0d76c1d0377b84165a07d3ebeaa4a4731c6eafe8f3a952942c85e38bf6db0f1d56abfc6f85664e1cad5f5259dd2083ce28e08d8ca9
diff --git a/dev-python/mecab-python/files/mecab-python-py3.diff b/dev-python/mecab-python/files/mecab-python-py3.diff
new file mode 100644
index 000000000000..33c8d97ebb2b
--- /dev/null
+++ b/dev-python/mecab-python/files/mecab-python-py3.diff
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -7,7 +7,7 @@
+ return os.popen(str).readlines()[0][:-1]
+
+ def cmd2(str):
+- return string.split (cmd1(str))
++ return cmd1(str).split()
+
+ setup(name = "mecab-python",
+ version = cmd1("mecab-config --version"),
diff --git a/dev-python/mecab-python/mecab-python-0.996.ebuild b/dev-python/mecab-python/mecab-python-0.996.ebuild
new file mode 100644
index 000000000000..29a4b4618d14
--- /dev/null
+++ b/dev-python/mecab-python/mecab-python-0.996.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for MeCab"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="http://mecab.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc64 x86"
+IUSE=""
+
+DEPEND="~app-text/mecab-${PV}"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-py3.diff" )
+DOCS=( test.py )
+HTML_DOCS=( bindings.html )
diff --git a/dev-python/mecab-python/metadata.xml b/dev-python/mecab-python/metadata.xml
new file mode 100644
index 000000000000..1ec95998be06
--- /dev/null
+++ b/dev-python/mecab-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="google-code">mecab</remote-id>
+ </upstream>
+</pkgmetadata>