summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-12 01:23:44 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-12 01:23:44 +0000
commitdcd546e83ea8dc078f6a8fdfa072d7beddf8f299 (patch)
tree1b6e4857b518bd7e4038812087359c3da0edb710 /dev-python/meshio/meshio-5.3.4.ebuild
parentdev-python/ansible-compat: add 2.0.0, drop 0.5.0 (diff)
downloadgentoo-dcd546e83ea8dc078f6a8fdfa072d7beddf8f299.tar.gz
gentoo-dcd546e83ea8dc078f6a8fdfa072d7beddf8f299.tar.bz2
gentoo-dcd546e83ea8dc078f6a8fdfa072d7beddf8f299.zip
dev-python/meshio: add 5.3.4, drop 5.3.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/meshio/meshio-5.3.4.ebuild')
-rw-r--r--dev-python/meshio/meshio-5.3.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/meshio/meshio-5.3.4.ebuild b/dev-python/meshio/meshio-5.3.4.ebuild
new file mode 100644
index 000000000000..24f6d8fde63d
--- /dev/null
+++ b/dev-python/meshio/meshio-5.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Input/output for many mesh formats"
+HOMEPAGE="https://github.com/nschloe/meshio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hdf5 netcdf"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ netcdf? ( dev-python/netcdf4-python[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/h5py[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest