summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-01 05:28:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-01 05:47:43 +0100
commit0bfae05817f2649a7b48606b780be30e6e59e43b (patch)
tree332fd747018e89192a05d9c594e270af1a9e0f1c /dev-python/meshio
parentdev-python/python-slugify: Bump to 8.0.3 (diff)
downloadgentoo-0bfae05817f2649a7b48606b780be30e6e59e43b.tar.gz
gentoo-0bfae05817f2649a7b48606b780be30e6e59e43b.tar.bz2
gentoo-0bfae05817f2649a7b48606b780be30e6e59e43b.zip
dev-python/meshio: Bump to 5.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/meshio')
-rw-r--r--dev-python/meshio/Manifest1
-rw-r--r--dev-python/meshio/meshio-5.3.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/meshio/Manifest b/dev-python/meshio/Manifest
index a388531bfe34..7fdedd5aa1a0 100644
--- a/dev-python/meshio/Manifest
+++ b/dev-python/meshio/Manifest
@@ -1 +1,2 @@
DIST meshio-5.3.4.tar.gz 492100 BLAKE2B 2eda13879b5cfd777201a668accfea82ee852ba729f5037584b9760eb1e9a2482a8d2e3ef7774271a38d88fba2533f012049040783e8abbd35ec4c3bb720ae52 SHA512 d8e7228045aa70d0a3ca5b113a24889f97aa327abe10d2c7bbc54ec358735117b6ba37b40fbf1a168f00f96a055d6940fd2f5cd0250e20c43c50ea7827e4d53d
+DIST meshio-5.3.5.tar.gz 490922 BLAKE2B ff6635db062b5e4041d7a4389f1e2fefc20cf55c1c0e70be1796c9e65e87daf503c7446224130eee94a3a2d0fb52dcd57ce3fa169afe7ca7fe32c3037fa21e00 SHA512 dcf6b914536b5b109ead378b7314de8f6f65ca7eb9b8c1092ce51308c32175c92a8f6386087b00770cd64eddcbc3fa80232dd30b370880894c0fa0b074bd7313
diff --git a/dev-python/meshio/meshio-5.3.5.ebuild b/dev-python/meshio/meshio-5.3.5.ebuild
new file mode 100644
index 000000000000..8bb43bf2183b
--- /dev/null
+++ b/dev-python/meshio/meshio-5.3.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Input/output for many mesh formats"
+HOMEPAGE="
+ https://github.com/nschloe/meshio/
+ https://pypi.org/project/meshio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hdf5 netcdf"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ netcdf? ( dev-python/netcdf4[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/h5py[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest