summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-12-12 18:16:21 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-12-12 18:17:01 +0700
commitad97be60ca65a58f35f9ea599fdc2856c706a7fd (patch)
tree4a77b87f9f563fc66f8e6cf818d6556891369a49 /dev-python/mpmath/mpmath-1.1.0.ebuild
parentnet-dns/unbound: bump to v1.8.3 (diff)
downloadgentoo-ad97be60ca65a58f35f9ea599fdc2856c706a7fd.tar.gz
gentoo-ad97be60ca65a58f35f9ea599fdc2856c706a7fd.tar.bz2
gentoo-ad97be60ca65a58f35f9ea599fdc2856c706a7fd.zip
dev-python/mpmath: bump to 1.1.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org> Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/mpmath/mpmath-1.1.0.ebuild')
-rw-r--r--dev-python/mpmath/mpmath-1.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mpmath/mpmath-1.1.0.ebuild b/dev-python/mpmath/mpmath-1.1.0.ebuild
new file mode 100644
index 000000000000..08a77279f3ea
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://mpmath.org/"
+SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="gmp matplotlib test"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}.patch"
+ )
+
+ # this test requires X
+ rm ${PN}/tests/test_visualization.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd ${PN}/tests >/dev/null
+ ${EPYTHON} runtests.py -local
+ popd >/dev/null
+}