summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-06 12:19:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-06 12:22:50 +0200
commit1c31208d076738aa6b242937c6e49876d74a2035 (patch)
tree49bfb70ebc72434c145beef8843486501d040ffa /dev-python/nbval
parentdev-python/pikepdf: Remove old (diff)
downloadgentoo-1c31208d076738aa6b242937c6e49876d74a2035.tar.gz
gentoo-1c31208d076738aa6b242937c6e49876d74a2035.tar.bz2
gentoo-1c31208d076738aa6b242937c6e49876d74a2035.zip
dev-python/nbval: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbval')
-rw-r--r--dev-python/nbval/Manifest1
-rw-r--r--dev-python/nbval/nbval-0.10.0.ebuild46
-rw-r--r--dev-python/nbval/nbval-0.9.6.ebuild38
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/nbval/Manifest b/dev-python/nbval/Manifest
index 954354fc1053..02fcdac85b9a 100644
--- a/dev-python/nbval/Manifest
+++ b/dev-python/nbval/Manifest
@@ -1,2 +1 @@
DIST nbval-0.10.0.tar.gz 62727 BLAKE2B 5b8d2815ec38481da1c0b3b5b62f809a231c4d136499b73ef13dba6a5214c87a5d4f77db1d81488e1bf13bd3ff365414e75760763a56a3cc28e752dd316ac009 SHA512 3e0e495db40aa4969e03ed1359f0c509b7470a54b3d8b6a85731601af5da0407bd44b3f069178f1a6b3aca7bf243747aaeaca4cb2332912e917e360f705eae61
-DIST nbval-0.9.6.tar.gz 60932 BLAKE2B 77f283279e16e03ec87f250b2012aabd8f580e24b222efcb0b21d9b0dadc381cea3c4a3f96a85df0104da86911de66e6c21bfd3985801fa9c3d8764b2fb26183 SHA512 d4261fc30e197e7350c07504649f0230751b5ed746fe4626b92c5920032dc15abe47ad421c93f4762e93a8b6afcbca440ca006bfd1cdbcba37d131c4e6decaa7
diff --git a/dev-python/nbval/nbval-0.10.0.ebuild b/dev-python/nbval/nbval-0.10.0.ebuild
deleted file mode 100644
index 2c358809e255..000000000000
--- a/dev-python/nbval/nbval-0.10.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="A pytest plugin to validate Jupyter notebooks"
-HOMEPAGE="https://github.com/computationalmodelling/nbval"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter-client[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/nbdime[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- )
- doc? (
- virtual/pandoc
- )
-"
-
-EPYTEST_IGNORE=(
- # Mocker not packaged
- tests/test_nbdime_reporter.py
-
- tests/test_coverage.py
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-rtd-theme \
- dev-python/numpy \
- dev-python/nbsphinx \
- dev-python/matplotlib
diff --git a/dev-python/nbval/nbval-0.9.6.ebuild b/dev-python/nbval/nbval-0.9.6.ebuild
deleted file mode 100644
index fe86aa202a5c..000000000000
--- a/dev-python/nbval/nbval-0.9.6.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
-HOMEPAGE="https://github.com/computationalmodelling/nbval"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter-client[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="test? ( dev-python/sympy[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests --install pytest
-
-python_test() {
- distutils_install_for_testing
- local deselect=(
- --deselect tests/test_ignore.py::test_conf_ignore_stderr
- --deselect tests/test_timeouts.py::test_timeouts
- )
-
- epytest "${deselect[@]}"
-}