summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 14:34:33 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 15:14:58 +0100
commitb10b8e4302b9459c55b6f50f3f1aac52dd28a294 (patch)
tree8d0303f6e78568a45c045654740bd8d8bc80f8e4 /dev-python/nbval
parentgnome-extra/libgsf: Bump to 1.14.48 (diff)
downloadgentoo-b10b8e4302b9459c55b6f50f3f1aac52dd28a294.tar.gz
gentoo-b10b8e4302b9459c55b6f50f3f1aac52dd28a294.tar.bz2
gentoo-b10b8e4302b9459c55b6f50f3f1aac52dd28a294.zip
dev-python/nbval: enable py3.10, fix tests
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/nbval')
-rw-r--r--dev-python/nbval/nbval-0.9.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/nbval/nbval-0.9.6.ebuild b/dev-python/nbval/nbval-0.9.6.ebuild
index dd3f21a47ef9..d5b82cd22c6d 100644
--- a/dev-python/nbval/nbval-0.9.6.ebuild
+++ b/dev-python/nbval/nbval-0.9.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
@@ -25,13 +25,14 @@ RDEPEND="
"
BDEPEND="test? ( dev-python/sympy[${PYTHON_USEDEP}] )"
-distutils_enable_tests pytest
+distutils_enable_tests --install pytest
python_test() {
+ distutils_install_for_testing
local deselect=(
--deselect tests/test_ignore.py::test_conf_ignore_stderr
--deselect tests/test_timeouts.py::test_timeouts
)
- pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+ epytest "${deselect[@]}"
}