summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-07 11:35:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-07 12:30:01 +0100
commit9b2e0ab1028b53d92ce4e1abd15c8a7c9b3bd9a4 (patch)
treef591828300c9d9fb0590d7fe9936f671fd2fc0f7 /dev-python/neovim-python-client
parentapp-vim/molokai: stable for amd64+x86. (diff)
downloadgentoo-9b2e0ab1028b53d92ce4e1abd15c8a7c9b3bd9a4.tar.gz
gentoo-9b2e0ab1028b53d92ce4e1abd15c8a7c9b3bd9a4.tar.bz2
gentoo-9b2e0ab1028b53d92ce4e1abd15c8a7c9b3bd9a4.zip
dev-python/neovim-python-client: add python3_6 to PYTHON_COMPAT.
Closes: https://bugs.gentoo.org/643600 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/neovim-python-client')
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.1.13.ebuild11
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.1.9.ebuild11
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild3
3 files changed, 11 insertions, 14 deletions
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.1.13.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.1.13.ebuild
index ba9be5d3944b..0e7fd586cc31 100644
--- a/dev-python/neovim-python-client/neovim-python-client-0.1.13.ebuild
+++ b/dev-python/neovim-python-client/neovim-python-client-0.1.13.ebuild
@@ -4,7 +4,6 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
inherit distutils-r1
DESCRIPTION="Python client for Neovim"
@@ -19,20 +18,18 @@ IUSE="test"
COMMON_DEPEND="
>=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
virtual/python-greenlet[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
-"
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
RDEPEND="
${COMMON_DEPEND}
- >=app-editors/neovim-0.1.6
-"
+ >=app-editors/neovim-0.1.6"
+
DEPEND="
${COMMON_DEPEND}
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
- )
-"
+ )"
S="${WORKDIR}/python-client-${PV}"
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.1.9.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.1.9.ebuild
index 5a383838e3fe..8ad3f64bc344 100644
--- a/dev-python/neovim-python-client/neovim-python-client-0.1.9.ebuild
+++ b/dev-python/neovim-python-client/neovim-python-client-0.1.9.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
inherit distutils-r1
DESCRIPTION="Python client for Neovim"
@@ -16,12 +17,10 @@ KEYWORDS="~amd64 ~x86"
DEPEND="
>=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
virtual/python-greenlet[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
-"
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})"
RDEPEND="
${DEPEND}
- >=app-editors/neovim-0.1.3
-"
+ >=app-editors/neovim-0.1.3"
S="${WORKDIR}/python-client-${PV}"
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild
index 66a5585d620d..9199fbf0576a 100644
--- a/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild
+++ b/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
inherit distutils-r1
DESCRIPTION="Python client for Neovim"