summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-19 01:23:39 +0000
committerSam James <sam@gentoo.org>2022-07-19 01:23:39 +0000
commitd2f8ebc7bf5082a40cfbb3cce97ac8282fc4829b (patch)
treea97d5a99c0eb915702fd5c7c3caa84357a3698fb /dev-python/networkx
parentmedia-libs/sdl2-mixer: add github upstream metadata (diff)
downloadgentoo-d2f8ebc7bf5082a40cfbb3cce97ac8282fc4829b.tar.gz
gentoo-d2f8ebc7bf5082a40cfbb3cce97ac8282fc4829b.tar.bz2
gentoo-d2f8ebc7bf5082a40cfbb3cce97ac8282fc4829b.zip
dev-python/networkx: add 2.8.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-2.8.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index f93a50fafee3..b9dc5e14633d 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1 +1,2 @@
DIST networkx-2.8.4.tar.gz 1951336 BLAKE2B f45708eb8a642ee2561caf6b82b8947cc0ed8a90e22ff3424c54db728f6ab91bbaf78c62da113d02325c8f56418690386143c74f2098c670fe102c4e5ec78b9d SHA512 3f874e08a55d924905506fabdba1540745f7a1a99745531b49442206b6cac9b911674441d2241bc2c3e8c173635d53f2e5677fe76936630236ffb3fa021b2f9a
+DIST networkx-2.8.5.tar.gz 1955125 BLAKE2B a98eb678f2d3b336e5675ac34b59677ead3d706347feb0150f553b49cad0f1936a5abf179eaa496e32b8e9d59103022e5103d9e2d758aac2df781f031254c2fb SHA512 0a4d50da0eff0ee7d79941d27bf07b5425493b92f482b4f91bd91a930e4e9c5eb1d3832aee44919aa708fd1e2d0a53fe2d77ff33864a54d0e3167b4108545dec
diff --git a/dev-python/networkx/networkx-2.8.5.ebuild b/dev-python/networkx/networkx-2.8.5.ebuild
new file mode 100644
index 000000000000..56ba57d5aeb2
--- /dev/null
+++ b/dev-python/networkx/networkx-2.8.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{8..10} )
+# networkx skips tests w/ missing deps and the available ones all pass w/ py3.11
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" python3_11 )
+inherit distutils-r1 optfeature multiprocessing virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # virtx implies nonfatal
+ nonfatal epytest -p no:django -n "$(makeopts_jobs)" || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "dev-python/gdal"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}