summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-10 18:55:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-10 22:11:55 +0100
commitfe0e02585f2e97cf5e937c8dc41fe4bb76323e33 (patch)
tree9cf5b72e80a6a0b12771cb49478439d90f85f0db /dev-python/oslo-concurrency
parentdev-python/mrcfile: Bump to 1.5.0 (diff)
downloadgentoo-fe0e02585f2e97cf5e937c8dc41fe4bb76323e33.tar.gz
gentoo-fe0e02585f2e97cf5e937c8dc41fe4bb76323e33.tar.bz2
gentoo-fe0e02585f2e97cf5e937c8dc41fe4bb76323e33.zip
dev-python/oslo-concurrency: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 94df29bc43f0..3f42c96cf8e9 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-5.2.0.tar.gz 60052 BLAKE2B 9f45af8beaa5fc145963e3e12818325dff2a00178c3154a4cf7ce2950ca90d9771be590593cc195c2909930416501da1042768da9ba653c0126437bb518a338e SHA512 9f645aa611882e1b7218a7fbf65b54fef523d9cf067f894e9441c0a8de3ab80495ec8a167604412385edf12fc7a53b73ac0ef63e977889db7021dd5b93b0d72f
+DIST oslo.concurrency-5.3.0.tar.gz 60677 BLAKE2B 72af8a54bbea85e7564c5c04463e106e16ab1608f7ae8662b1e5db3cc07d07b0bd2531dedd9227d6823700c0e93e3c160afe7ddf27f6023715e62b787246fb64 SHA512 6f3adc558a7879ae05bfbfa30dfa4c687e5f1cd6385a6881b2e1647b116aab5816d1333b42bac0c8554685ea2ac3ee293d5b9dc836c214bb708e2d53a6971639
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild
new file mode 100644
index 000000000000..8706152fbfa1
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency/
+ https://pypi.org/project/oslo.concurrency/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails, then hangs
+ rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}