summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:08:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:08:34 -0500
commite77865da21ac6ce79d34874b360b462b3d4c7947 (patch)
treea16fe4339dd1b6bbb772a410e593b91f9c1ec5ff /dev-python/osprofiler/osprofiler-1.2.0.ebuild
parentdev-python/castellan: bup for mitaka (diff)
downloadgentoo-e77865da21ac6ce79d34874b360b462b3d4c7947.tar.gz
gentoo-e77865da21ac6ce79d34874b360b462b3d4c7947.tar.bz2
gentoo-e77865da21ac6ce79d34874b360b462b3d4c7947.zip
dev-python/osprofiler: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/osprofiler/osprofiler-1.2.0.ebuild')
-rw-r--r--dev-python/osprofiler/osprofiler-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/osprofiler/osprofiler-1.2.0.ebuild b/dev-python/osprofiler/osprofiler-1.2.0.ebuild
new file mode 100644
index 000000000000..5c1c29e0d4a2
--- /dev/null
+++ b/dev-python/osprofiler/osprofiler-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Profiler Library"
+HOMEPAGE="https://launchpad.net/osprofiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+"