summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-09 08:06:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-09 08:32:31 +0200
commit7df738761c1cfa16e62eb2f3d1b581a9b72d8ede (patch)
treead8445b6f81e350e699d7427ee5ca5e21d2681dc /dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
parentdev-python/blurb: Bump to 1.1.0 (diff)
downloadgentoo-7df738761c1cfa16e62eb2f3d1b581a9b72d8ede.tar.gz
gentoo-7df738761c1cfa16e62eb2f3d1b581a9b72d8ede.tar.bz2
gentoo-7df738761c1cfa16e62eb2f3d1b581a9b72d8ede.zip
dev-python/osrf_pycommon: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild')
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
new file mode 100644
index 000000000000..b096ab70236b
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linting is something upstreams do
+ # for us, it either means unneeded deps or breakage due to changes
+ tests/test_code_format.py
+)