summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-08 16:24:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-08 16:33:46 -0600
commit124b15f1b2cce2b16109cc0c6e5dfc116de68904 (patch)
tree9958bb7f0f2f4dc584b0b04c2da1e96a658827f8 /dev-python/ovs/ovs-2.6.1.ebuild
parentapp-emulation/rkt: version bump to 1.22.0 (diff)
downloadgentoo-124b15f1b2cce2b16109cc0c6e5dfc116de68904.tar.gz
gentoo-124b15f1b2cce2b16109cc0c6e5dfc116de68904.tar.bz2
gentoo-124b15f1b2cce2b16109cc0c6e5dfc116de68904.zip
dev-python/ovs: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/ovs/ovs-2.6.1.ebuild')
-rw-r--r--dev-python/ovs/ovs-2.6.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ovs/ovs-2.6.1.ebuild b/dev-python/ovs/ovs-2.6.1.ebuild
new file mode 100644
index 000000000000..dea283675c80
--- /dev/null
+++ b/dev-python/ovs/ovs-2.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OVS bindings for python."
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!<net-misc/openvswitch-2.6.0-r2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "