summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:07:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:13:01 +0300
commitcf8627998040b708cfcd27bad7ec9603e889854b (patch)
tree2ba4d41a0a76bb017c5cdbd591f233245b1e6c04 /dev-python/owslib/owslib-0.20.0.ebuild
parentdev-python/mechanize: drop 0.4.6 (diff)
downloadgentoo-cf8627998040b708cfcd27bad7ec9603e889854b.tar.gz
gentoo-cf8627998040b708cfcd27bad7ec9603e889854b.tar.bz2
gentoo-cf8627998040b708cfcd27bad7ec9603e889854b.zip
dev-python/owslib: drop 0.20.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/owslib/owslib-0.20.0.ebuild')
-rw-r--r--dev-python/owslib/owslib-0.20.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/owslib/owslib-0.20.0.ebuild b/dev-python/owslib/owslib-0.20.0.ebuild
deleted file mode 100644
index cbb73ccd6a1a..000000000000
--- a/dev-python/owslib/owslib-0.20.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
-HOMEPAGE="https://geopython.github.io/OWSLib/"
-SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-S="${WORKDIR}/OWSLib-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-RESTRICT="test" # tests require WAN access
-PROPERTIES="test_network"
-
-PATCHES=( "${FILESDIR}/${P}-no-privacybreach.patch" )
-
-src_prepare() {
- sed -e '/addopts/d' -i tox.ini || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- epytest --tb=native --ignore=setup.py --doctest-modules --doctest-glob 'tests/**/*.txt'
- #"${EPYTHON}" "${S}/setup.py" test || die
-}